Software Downloads

PC OS requirements:

Windows 10, Windows 8 or 8.1 (32- or 64 bit), Windows 7 SP1 or newer (32- or 64 bit)

Mac OS requirements:

OS: MacOS 10.9 Mavericks - 10.14 Mojave

GLM software is not currently supported under macOS 10.15 Catalina. 
Please check this page regularly to obtain information on the current operating system requirements. In the meantime, we recommend you continue to use macOS Mojave and earlier until further notice. Mac OS X 10.15 (Catalina) users can follow the method below to use GLM 3 at the moment.

Installing GLM 3 in Catalina computer.pdf   

Latest release

GLM 3 software calibrates and controls Genelec SAM monitors and subwoofers using Genelec Network Adapter model 8300-416.

Genelec Network Interface models 8200-416 and 8200-416B are not supported with GLM 3 software.

See the latest release note for further details.

Sinulla ei ole tarvittavia rooleja tähän portlettiin.