Message Boards

GLM 2 adapter disturbs some of my old analog equipment

kire, modified 2 Years ago.

GLM 2 adapter disturbs some of my old analog equipment

Youngling Posts: 16 Join Date: 5/10/09 Recent Posts
I have a GLM 2 adapter with a pair of 8240s. I've noticed that some of my old analog equipment picks up disturbances from this box, I hear a periodic "pulse" coupled to the communication on the Ethernet cable (in sync with the yellow led on the back of the box). If I disconnect the Ethernet cable it's silent (I'm using shielded Ethernet cables etc.). Any ideas what do do others than to replace the old gear? (in this case a NAD preamp)
markus-kahelin, modified 2 Years ago.

RE: GLM 2 adapter disturbs some of my old analog equipment

Jedi Knight Posts: 109 Join Date: 3/16/10 Recent Posts

Hi!

I think we have never had similar issues before. As always the good way to eliminate analog audio issues is to ensure that your signal is running in balanced line level cables and that you have good grounding on the power feed of your equipment. Also cable runs should have distance between them to eliminate possible noises.

 

Best Regards, Markus

Genelec Oy

kire, modified 2 Years ago.

RE: GLM 2 adapter disturbs some of my old analog equipment

Youngling Posts: 16 Join Date: 5/10/09 Recent Posts
Thanks, I'll go through the equipment, cabeling etc. This particular preamp is a 25 year old NAD consumer model using RCAs (but balanced cables to speakers), I'm not surprised it's picking up disturbances.